We are pleased to inform you the Bloomreach search dashboard is now accessible to all clients.
Regards, Bloomreach Support Team
Posted Jul 31, 2026 - 10:33 CEST
Update
We are continuing to monitor for any further issues.
Posted Jul 31, 2026 - 10:25 CEST
Monitoring
Dear Customers,
A fix has been implemented and we are monitoring to confirm the incident has been resolved.
Regards, Bloomreach Support Team
Posted Jul 31, 2026 - 10:14 CEST
Investigating
Dear Customers,
We are aware that clients are experiencing issues logging in to the Bloomreach search and merchandising dashboard. Our engineering teams are actively working on this issue, and we will keep you posted on further updates related to this incident.