Degraded campaigns performance on EXP

Incident Report for Bloomreach

Resolved

The situation has been resolved, and the infrastructure is stable and functioning as expected.
Posted Aug 19, 2025 - 08:54 CEST

Monitoring

We are actively monitoring; the situation has been identified and improvements implemented.
Posted Aug 18, 2025 - 12:22 CEST

Investigating

We are currently investigating this issue.
Posted Aug 15, 2025 - 13:23 CEST
This incident affected: Bloomreach Engagement (EXP).