We are pleased to inform you the Bloomreach dashboard is now accessible to all clients.
Regards, Bloomreach Support Team
Posted Jul 28, 2026 - 17:26 CEST
Monitoring
Dear Customers,
A fix has been implemented and we are monitoring to confirm the incident has been resolved.
Regards, Bloomreach Support Team
Posted Jul 28, 2026 - 17:01 CEST
Identified
Dear Customers,
The root cause has been identified, and our teams are working on implementing the fix.
Regards, Bloomreach Support Team
Posted Jul 28, 2026 - 16:18 CEST
Investigating
Dear Customers,
We are aware that some clients are intermittently experiencing issues logging in to the Bloomreach search and merchandising dashboard. Our engineering teams are actively working on this issue, and we will keep you posted on further updates related to this incident.
Regards, Bloomreach Support Team
Posted Jul 28, 2026 - 15:59 CEST
This incident affected: Bloomreach Discovery (Discovery US, Discovery EMEA).